异常500,程序异常,Exception
当前位置:Exception500 » Dubbo » Apache Dubbo反序列化漏洞(CVE-2019-17564)

Apache Dubbo反序列化漏洞(CVE-2019-17564)

来源:exception500.com    发布时间:2020-02-15 18-41-54    浏览次数:193次

一、概要

近日,各大云服务商关注到Apache Dubbo存在反序列化漏洞(CVE-2019-17564)。Apache Dubbo是一款应用广泛的高性能轻量级的Java RPC分布式服务框架,当Apache Dubbo启用HTTP协议之后,在接受来自用户远程调用请求时存在一个不安全的反序列化行为,最终可导致远程任意代码执行。

Exception500网提醒使用Apache Dubbo的用户及时安排自检并做好安全加固。

参考链接:

https://www.mail-archive.com/dev@dubbo.apache.org/msg06226.html


二、威胁级别

威胁级别:【重要】

(说明:威胁级别共四级:一般、重要、严重、紧急)


三、漏洞影响范围

影响版本:

2.7.0 <= Apache Dubbo <= 2.7.4

2.6.0 <= Apache Dubbo <= 2.6.7

Apache Dubbo = 2.5.x


四、漏洞处置

1、升级版本:目前官方已在最新版本中修复了该漏洞,请受影响的用户升级至安全版本。

2、临时规避措施:通过禁用Dubbo中的HTTP协议对漏洞进行临时规避。目前,华为云、阿里云WAF已具备对该漏洞攻击的防御能力,WAF用户将Web基础防护的状态设置为“拦截”模式即可,具体方法请参见 配置Web基础防护规则。

注:修复漏洞前请将资料备份,并进行充分测试。


[关键词: DubboApache ]

  • 上一篇:没有了
  • 下一篇:没有了
软件开发 程序错误 异常 500错误 Exception Copyright© 2019-2020  Exception500 版权所有  【蜀ICP备15020376号-9】  网站地图